Oglinditul unui numar   Leave a comment

Oglinditul unui numar:

 

n c ogl
1472 2 2
147 7 27
14 4 274
1 1 2471

 

ogl=ogl*10+c

Pseudocod:

start

citeste n

ogl=0

cat timp n!=0 executa

c=n%10

n=n/10

ogl=ogl*10+c

scrie ogl

stop

 

Posted 21 Noiembrie 2010 by Isabela in Informatica

Cifrele unui numar   Leave a comment

2.Cifrele unui numar

a.Enunt

Se da un numar natural n.Se cere sa se afiseze cifrele sale.

b.Exemplu:

n=1472

n c
1472 2
147 7
14 4
1 1
0  

c=n%10

n=n/10

c.Algoritmul este urmatorul:

-se citeste n;

-cat timp n!=0 executa:-aflam uc(c=n%10)

-eliminam uc(n=n/10)

-afisam cifra

d.Pseudocod

start

citeste n

cat timp(n!=0) executa

c=n%10

n=n/10

scrie c

stop

e.Observatii:

-nr.  N se modifica

-cifrele nr.se afla in ordine inversa

 

Posted 21 Noiembrie 2010 by Isabela in Informatica

Cmmmc   Leave a comment

1.Cmmmc

Cmmmc prin adunari repetate

X y a b
20 35 20 35
40 35    
40 70    
60 70    
80 70    
80 105    
100 105    
120 105    
140 140    

 

Pseudocod:

Start

Citeste x,y

a=x

b=y

cat timp(x!=y) executa

daca (x<y) atunci  x=x+a

altfel y=y+b

scrie x

stop

 

Posted 21 Noiembrie 2010 by Isabela in Informatica

Cmmdc   Leave a comment

I.Cmmdc

a.Enunt: Se dau 2 numere, a si b.Se cere sa se determine Cmmdc-ul lor.

b.Exemplu:

a b
90 42
48 42
6 42
6 36
6 30
6 24
6 18
6 12
6 6

 

 

 

 

 

 

Cmmdc(a,b)=6

Cmmdc(90,0)=90

Cmmdc(0,80)=80

a=0–Cmmdc=b

b=0—Cmmdc=a

a*b=0—Cmmdc=a+b

c.Algoritmul:

-citim a si b;

-daca a*b=0 scrie a+b;

-altfel cat timp a!=b executa

Daca a>b atunci scade din a pe b

Altfel scade din b pe a

-afiseaza a.

d.Pseudocodul

start

citeste a,b

daca a*b=0 atunci scrie a+b

altfel cat timp a!=b executa

daca a>b atuncia=a-b

altfel b=b-a

scrie a

stop

e.Observatii

1.Numarul se modifica.Daca dorim sa folosim numarul dupa calculul Cmmdc atunci trebuie sa le facem o copie:x=a si y=b.

2.Algoritmul este lent din punct de vedere al timpului.

II.Algoritmul lui Euclid pentru determinarea Cmmdc

a.Enunt:Se cere sa se calculeze Cmmdc a doua numere.

b.Exemplu:

a b r
90

42

42

6

6

0

c.Algoritmul

-citim a si b;

-calculam restul(r=a%b);

-cat timp r!=o executa

a=b

b=r

r=a%b

-scrie b

d.Pseudocodul

start

citeste a,b

r=a%b

cat tmp r!=0 executa

a=b

b=r

r=a%b

scrie b

stop

e.Observatii

1.In urma calcularii Cmmdc numarul se modifica; pentru a le folosi apoi trebuie sa realizam o copie a lor.

2.Algoritmul lui Euclid este mai rapid decat algoritmul prin scaderi repetate pentru ca foloseste impartire.

 

Posted 14 Noiembrie 2010 by Isabela in Despre